Skip to main content.
Monday, April 17th, 2006

FC5, Prism2.5 News

Well, I was right. Once I rebooted, I could not get the D-Link DWL-520 rev E wireless network card running again.

I was following the most optimistic instructions I could find, which specifically addressed this card under Fedora Core 5. I installed the hostap-utils rpm, the firmware files, and made the edits to /usr/sbin/hostap_fw_load, and ran the firmware loader. I wish, wish, wish that I had have recorded the output of host_fw_load the time when it actually worked, because I’ve noticed the output vary, and give different reasons why it didn’t work.

After I upgraded my packages while the card was working, I rebooted with the newer kernel, 2.6.16. I don’t know why it was 16 instead of 20, which is the 2.6 kernel I’m running on my FC4 machine, but switching back and forth hasn’t helped. I never used make to compile anything, so I don’t see how changing the kernel has created more problem for me. Perhaps firmware incompatibilities?

Now, every time I run the firmware loader I destroy something. If I run iwconfig when I first start the machine, I see the card both at wifi0 and wlan0. When I run hostap_fw_load once, it reports loading the primary firmware, and wlan0 usually disappears. If I run it again, it reports loading the secondary firmware, it says it doesn’t work because there’s no such device as wlan0, and wifi0 disappears. The only way I know how to get them back is to reboot.

Posted by Greg in Hardware & Drivers, Networking, OS

1 Comment »

This entry was posted on Monday, April 17th, 2006 at 12:09 PST and is filed under Hardware & Drivers, Networking, OS. You can follow any responses to this entry through the comments RSS 2.0 feed. Both comments and pings are currently closed.

One Response to “FC5, Prism2.5 News”

  1. Ramblings » Blog Archive » FC5 and Wireless Card says:

    […] my FC5 machine is still not connected. I did go back and found that I had more notes that look like they went up to the point that I got the card working with the 2.6.15 kernel, but […]